読者です 読者をやめる 読者になる 読者になる

Android Studioでアプリ開発!

Androidアプリ開発初心者の備忘録です。

Google PlayにAPKをアップロードしたときに出るエラーの対処法(Google Play 開発者サービスのバージョン 5208000 を使用する APK をアップロードしました。バージョン 5100000 以下を使用してください。)

Google Play に APK をアップロードしたらエラーが出た

作った Android アプリの最新版を Google Play にアップロードしたらエラーが出ました。

アップロードできませんでした
Google Play 開発者サービスのバージョン 5208000 を使用する APK をアップロードしました。バージョン 5100000 以下を使用してください。

スクリーンショットはこちら。
f:id:jolene:20140814105148p:plain

エラーが出る原因

Google Play services を最新版(5.2.08)にアップデートしたところ、今回のエラーが出るようになりました。
どうやらこれが悪いようです。

改善策

build.gradle で Google Play services のバージョン指定を 5100000 以下にする。

dependencies {
//    compile 'com.google.android.gms:play-services:5.2.08'
    compile 'com.google.android.gms:play-services:5.0.89'
    compile fileTree(dir: 'libs', include: ['*.jar'])
}

過去の Google Play services のバージョンは Android Studio.app 内にあります。詳しくは以下のスクリーンショットを参照してください。
f:id:jolene:20140814105918p:plain

これで無事、APK をアップロードできました。

不満

配布されている最新バージョンを使うとアプリをリリースできないなんて...

はじめてのAndroidアプリ開発―Android4対応版 (TECHNICAL MASTER)

はじめてのAndroidアプリ開発―Android4対応版 (TECHNICAL MASTER)

Android StudioではじめるAndroidプログラミング入門

Android StudioではじめるAndroidプログラミング入門